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1. About “eResults” 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The  “e-Results” covers most of the features of automation of examination system. 

Currently Exam cell activity mostly includes a lot of manual calculations and is mostly paper 

based. The current system of managing results and examination is facing a problem which is 

hampering the automation of examination system. The project aims to bring in a centralized 

system that will ensure the activities in the context of an examination that can be effectively 

managed. It serves as an automated software which handles the most tedious and complex 

process handled during the examination times by the exam cell of a college. 
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2. Logging In: 
 

In order to get access to the system, the user needs to Log On by entering his/her UserID and 

Password. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

After clicking the Log In button, the user will be directed to the homepage of eResults.  
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3. Homepage: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The homepage consists of various elements like Dashboard, Organization, Students, Faculty, Pre-

conduct, Post-Conduct and Settings.  
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4. Dashboard: 
 

The Dashboard is actually a search page to search for a student, faculty member, course 

or department.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

On the Dashboard window, a user can search for a student by entering his/her name or Roll.  

No. in the textbox provided. This will display the list of items matching the entered text.  

Same procedure applies for faculty, course and department.  
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5. Organization: 
 

The organization window is where various Schools, their Departments, programs, Board of 

Studies and Courses can be added, viewed and modified.  
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6. Schools: 
 

To add a school, Click on the “Add” tab.  

Enter the details of the School in the fields provided and click “Add” button to add a 
 

school.  

The message will be displayed that school has been added successfully meaning that 

you can proceed further.  

Similarly the “Update” tab is where a user can update the details of a School.  

Under the “View” tab a user can view all the Schools that have been added so far.  
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7. Departments: 
 

A user can add departments to a particular School by clicking on that School under 
 

the “View” tab in Schools.  

The procedure for adding or modifying Departments is same as that of Schools.  
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8. Programs: 
 

Under the “View” tab in Schools > Departments, the list of Departments will appear. 
 

A user can click on the particular department to which he/she wants to add 

or modify a program.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

To add a Program, click the add tab under Schools > Departments > Programs and 

enter the details of that program in the fields provided.  

The “Add” button finally adds the School to the database. 
 

The message program added successfully will be displayed meaning that school has 

been added and the user can proceed.  

To update a program click on the “Update” tab. 
 



 pg. 11 

 

9. Board of Studies: 
 
 

By Clicking the program under “View” tab in Schools > Departments > Programs, a 

user can add or modify Board of Studies.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click the “Add” tab under Schools > Departments > Programs > Board of Studies to 

add a new Board of Studies. 
 

The message Board of Studies added successfully will be displayed after 

successful attempt. 
 

Under the “View” tab a user can check all the Board of Studies of a particular 

program.  
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10. Courses: 
 

A user can add courses the clicking in the Board of Studies view details 

under Schools > Departments > Programs > Board of Studies.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Under the “Add” tab a user can upload an excel file of courses whose format can be 

downloaded by clicking “Sample Format” link. 
 

The excel file must be strictly cross checked so that there is no mistake later 

in tabulation.  

The format of excel file for courses is like the following.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The format must be same as above.  

When the “Choose File” field turns into green colour, it means that the file is 
 

uploaded successfully.  

By clicking on the “Load Excel File” button, the contents of the file will be 

displayed.  
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The “Add Courses” button below the contents of file will add the excel file to 

database and the message will be displayed showing “Courses added successfully”. 
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The Courses that were added can be viewed simply by clicking “View” tab under 
 

Schools > Departments > Programs > Board of Studies > Courses.  
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11. Students: 
 

The Students window will enable users to add or view students of the varsity.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To add a Student, click the “Add” tab under Students, enter the Programme name in 

textbox provided and select the excel file. 
 

The excel file must have the format as shown below, the format can also 

be downloaded by clicking “Sample Format” link.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Make sure that there are no mistakes in the excel file and has the format exactly same 

as shown.  

When the “Choose File” field turns green, it means the file is uploaded. 
 

To load the contents of the file click the “Load Excel File” button. The result will be 

same as shown below. 
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Finally a user can click “Add Students” to add the students to database. 
 

If there is no error, the message File Uploaded Successfully will be displayed on 

the window. 

To view students, click on the “View” tab under Students.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Enter the name of a Programme in textbox and click “Go” button. 

The students’ list will be displayed. 
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12. Faculty: 
 

The Faculty window is where a user can add, update or view the faculty details.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

To add faculty, click the “Add” tab under the Faculty. 

 

The Faculty must be first added to an excel file, whose format can be downloaded by clicking 

“Sample Format” link.  

The format must be cross checked and must be exactly same as the one mentioned.  

The format for faculty is shown below.  
 
 
 
 
 
 
 
 
 
 

 

When the “Choose File” field turns green, click the “View” button to display 

the contents of the file.  

Finally the “Add” button will be used to add faculty to the database. 
 

Upon successful completion, the message “Faculty Added Successfully” will be 

displayed. 
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Under the “View” tab a user can view the faculty by clicking “View” button. This 

will display the list of faculty with their details.  

 

The “Update” tab under faculty will update the specialization of faculty. A user can add a 

specialization or delete a specialization of a particular faculty member.  

The update can be done by searching for the faculty and clicking the “Edit” button.  
 

Under the Edit Faculty Details, the Faculty Email, Faculty Phone and Specialization 

Textboxes will be automatically filled.  

In the specialization textbox, a user can delete or add another specialization.  

Finally the “Update” button must be clicked to make the changes. 
 

Here a user can also search according to specialization by entering the specialization in the 

Faculty Name textbox and clicking the “Search” button. 
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13. Pre-Conduct 
 

The Pre-Conduct process involves creating sessions, selecting courses and paper setting 

process. 
 

The Pre-Conduct involves two working modules Sessions and Paper Setting.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Examination Session:  
Click on the Create Session tab to create a new session. 

 

Enter the details in provided fields and click “Create” button. The new session will 

be added to database after the message Session Created Successfully is displayed 

on the window. 
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After the session is created, a user has to select courses from a tree view whose 

examination is to be conducted in a particular session under the “Select 

Courses” tab.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The non-elective courses will be automatically selected and the elective courses are 

to be selected by the user.  

The sessions can be viewed under “View” tab in Examination Session by clicking 
 

view button.  
Under “View” tab the details of the session can be viewed.  
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14. Paper Setting: 
 

Under this module, a user can assign course to a faculty to set its paper. This is also helpful 

in viewing details of faculty who have already set the papers. 

 

Under the “Assign” tab the Session Name textbox and Programme textbox are 

filled and “Show” button lists the faculty. 

A user can assign faculty for the courses to set papers. The secret code and number 

of sets can also be set.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The “Submit” button finally saves the paper setters and related details in database. 
 

The “View” tab is where a user can check the details of paper setting like faculty who 

has set the paper, number of sets, secret code, etc. 
 

Under this tab the cover letter can be downloaded by clicking the “Download Cover 

Letter” button. 
 

The cover letter will be downloaded in PDF format and has the format as 

below. This cover letter is automatically generated as per the inputs. 
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Under the “Receipt” tab, the user can acknowledge that the paper has 

been received and the faculty is eligible for payment.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The fields are to be filled and the “Submit” button saves the inputs. 
 

This completes the Pre-Conduct process.  
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15. Post-Conduct: 
 

The Post-Conduct process involves paper checking and tabulation of marks. 
 

Paper Checking:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The “Assign” tab under the Paper Checking is used to assign faculty for 

checking papers. 
 

In the textboxes provided, a user can enter Session Name and Programme and then 

click “Show” button to load the courses and textboxes for faculty and secret code. 
 

After assigning faculty and secret code, a user has to click on “Submit” button to save 

the data.  
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To check the details of paper checkers and payment status the user may click on “View” 

tab under Paper Checking.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The necessary details need to be filled and clicking the “View” button will display the 
 

details like session, course code, number of papers checked, etc.  

Under the “Receipt” tab, the user can acknowledge that the papers have been checked by 

the faculty they were assigned to, and they are eligible for payment.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The user needs to fill the given fields like session name, Programme, Number of 
 

Papers Checked, etc. and then clicking the “Submit” button will save the inputs.  
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16. Tabulation: 
 

In this module, a user has to enter the marks details of students. 
 

Under the “Marks Entry : Home” tab, a user has to enter the details mentioned.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

After entering correct details the user can click the “Next” button to proceed. 
 

Next tab namely “Marks Entry : Courses” will be shown after clicking “Next” button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The list of courses of the Programme selected will be displayed, and the user can 

enter the Internal or External Marks by clicking the “Submit” button. 
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Clicking the “Submit” button will direct user to a “Marks Entry : Editor” tab 

where the list of students under the Programme selected will be displayed with 

textboxes for filling the marks. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

For External there will be textboxes for code numbers as well. 
 

To cross check the marks and code number entered, the user will have to confirm the 

marks and the code number to make sure that there is no mistake. 
 

When marks of all the courses are filled, the “Submit” buttons on the “Marks Entry 
 

: Courses” will be automatically disabled and will show the status “Completed” 

and the final “Submit” button will be enabled automatically. 
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The “Submit” button may be clicked to finally submit the award rolls. On successful 

completion, the message “Award Rolls Submitted Successfully” will be displayed on 

the window. 
 

This will enable the buttons “Download Marksheet” “Download Result” and 

“Download Result Statement” where a user can download the printable report of 

these documents. 
 

The format of Marks Sheet will be like the one shown below.  
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The format of Result Statement will be like the one below:  
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Similarly the Result or Gazette has the format similar to the one shown below.  
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17. Settings: 

 

User Management: 
 

The User Management Page is where an admin can create users, assign rolls, delete 

the existing roles and view users. 

 

Under the “Create User” tab, a new user can be created by entering his/her valid details 

like email and password. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The “Create User” button will add the details to database and will display message 

“User Created Successfully”. 
 

Under the “Add Roles” tab, the admin can create a new role.  
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Similarly under “View Roles” tab, a user can view or remove the existing roles.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The “Assign Roles” tab can be used by admin to assign roles to the users by entering 

username and role name. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

The “View User” tab displays the users and their roles. Here the admin can revoke a role 

from a user by clicking “Revoke” button under that under. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


